What are the minimum requirements to run WordPress?

Posted by Pinki | Updated on

Below are minimum requirements to run WordPress:

1. WordPress version should be the latest version. It is always recommended to use the latest and stable version of WordPress (As of date, the latest version is WordPress 3.4–4.9.6).
2. The system should have a version of PHP 5.3 and greater than (includes PHP 7).
3. For DB, it should have MySQL 5.6 or above OR MariaDB 10.0 or above.
4. System memory should have a minimum of 128MB RAM (depends on the theme, content and all plugins).
5. The eval() PHP function and Multibyte String extension (mbstring) must be enabled in the system.
6. It should be mod_rewrite Apache module.
7. It is recommended to use HTTPS support.


If you like this question & answer and want to contribute, then write your question & answer and email to freewebmentor[@]gmail.com. Your question and answer will appear on FreeWebMentor.com and help other developers.

Related Questions & Answers